FORUMS


Support for old graphic cards



Posted: //
July 5, 2018, 4:17 p.m.


Updated //
July 5, 2018, 4:31 p.m.

Hi. I have a computer from 2008 and in it ATI HD RX3850 graphics card. I can not play this game. Tried a new driver, it does not work. I play War thunder, assassin's creed 2... When I try to start this game I'm getting a notification that I need a newer driver, I've got it updated and it's the same again. Thanks.


Posted: //
July 5, 2018, 4:44 p.m.



Kruna301#9926 posted (#post-223159) said:

Hi. I have a computer from 2008 and in it ATI HD RX3850 graphics card. I can not play this game. Tried a new driver, it does not work. I play War thunder, assassin's creed 2... When I try to start this game I'm getting a notification that I need a newer driver, I've got it updated and it's the same again. Thanks.

Hey there,

In the game's current state, these are the system specs for Dreadnought:

Minimum

  • Intel Core i5-2300 2.8 GHz or AMD FX 6300 3.5 GHz - AMD APU A10-7890K 4.1 GHz
  • NVIDIA 750 Ti 1GB or AMD Radeon 7850 1GB
  • HDD with 30+ GB free space available
  • Windows 7, 8, 8.1, 10 (64-bit)
  • 4 GB of RAM

Recommended

  • Intel Core i5-6600K 3.5 GHz or AMD FX-9590 4.7 GHz
  • NVIDIA GeForce GTX 970 4 GB or AMD Radeon R9 390 4 GB
  • HDD or SSD with 30+ GB free space available
  • Windows 7, 8, 8.1, 10 (64-bit)
  • 8 GB of RAM

It looks like your graphics card doesn't meet our minimum requirement to run the game. You can find a side-by-side comparison of your gfx card and Dreadnought's minimum gfx card here. Hope that helps! I would suggest playing on a machine that does meet the minimum requirement!


VAQSeeN - Customer/Technical Support on Player Relations

Having game/tech issues? Submit a support ticket here!

This forum is restricted, posts cannot be made.