FORUMS


Australia - Game unplayable on ADSL2 10/1



Posted: //
Dec. 10, 2016, 5:58 p.m.



Hi Guys smile

Got my beta key yesterday, thought great lets have a go.

Did all the training stuff no issues, but once into a game it is unplayable for me.

I am guessing the servers are in EU? I play MWO and on occasion I play on their EU servers run at around 400-500ms and the game runs fun, yep I am a bit slow but I still get kills etc.

The game is jumping all over the place, but that's understandable in a beta I guess.

Anyway at this stage its an uninstall.


Posted: //
Dec. 10, 2016, 6:22 p.m.



the servers are in america there's no eu servers
and even people in the eu have been reporting alot more latency issues since the latest 1.3 patch


World of dreadnoughts ftw!


Posted: //
Dec. 10, 2016, 9:27 p.m.



Player from australia here and its great to hear another has joined! Im guessing it is your internet provider or connection that is giving you issues as im able to play with no problem whatsoever. Servers are american i believe, so you would expect around 250 to 300 ping. But that doesnt really affect gameplay.


Posted: //
Dec. 10, 2016, 9:45 p.m.


Updated //
Dec. 10, 2016, 9:45 p.m.

I'm across the ditch here, and running fibre. When I did play on ADSL, the game worked just fine for me - since progression 2.0 there have been more problems. This is even in spite of the fact that I upgraded to fibre before the update.

I'm inclined to think the issues are because of the massive reduction in playerbase (look through the forums, it's pretty hard to NOT see why people are quitting). Lack of players means more spread out players means longer round-trip pings between players. It all adds up to longer delays for the game to let you know what each other player is doing, even if your own connection is ok - and with 10/1 ADSL, your connection is only "ok" and not particularly great.

There are possible ISP-related routing issues which might be part of the problem, as well. I'm inclined to think that, if the devs actually stop trying to ram progression 2.0 down everyone's throats and realise we don't want it (poll is suggesting that's the case so far, at least https://www.greybox.com/dreadnought/en/forum/topic/35222/ ), the playerbase will pick back up. With more players, you'll have less high-ping players. With less high-ping players, you'll have better overall latency in the game, and better play experience as a result.


http://i.imgur.com/f5SVkIz.jpg
---V^^^V---
Step into your daydreams, and follow them home


Posted: //
Dec. 11, 2016, 6:17 a.m.



Agreed. Even in Eu the lag kills all chances of playing artillery ships and even affects Dreadnought play. Corvettes jumping around like they'd have teleporters, long distance fire missing when firing at ships that are supposed to be hoving still...it's a mess. Speedtest gives me reading of 13/3 and I can play faster paced games just fine.
The game also seems to drop frames and freezes every now and then, especially when there's heavy particles, yet the benchmarks give me a 65fps on ultra settings (gtx1080, i7-6700 and 16gb ram). I'm inclined to say it's the servers that are the issue here.


Posted: //
Dec. 11, 2016, 4:55 p.m.



been playing from AU (N-QLD) since the start - it has always been fine from here.


Posted: //
Dec. 18, 2016, 11:36 p.m.



Thanks for the reply's all smile

All I can say is I play other international MMO Games and do not have any major issues (most of the time).

Cheers

This forum is restricted, posts cannot be made.