FORUMS


Update 1.4: Can't equip Flak Turret II on Trafalgar - Error Displayed



Posted: //
Dec. 13, 2016, 5:27 p.m.



I get this error when trying to equip.


Posted: //
Dec. 13, 2016, 5:52 p.m.



DamnTheseVoices#5710 posted (#post-78065)

I get this error when trying to equip.

Same thing here!


-----Tier 5 Ohkta Pilot-----Tier 5 Invictus Pilot-----Tier 5 Athos Pilot-----
-------------------------Fully Researched Tier 4 Fleet------------------------
-------------------What the @#$% are you talking about?----------------


Posted: //
Dec. 14, 2016, 4:54 a.m.



Same here for me. But its not just the trafalgar. I can't buy II secondarys on all my t2 ships.
For T3 ships i was not yet able to try, cause i lost all my ship xp and unlocked modules with my Otranto after patch 1.4 smile


Posted: //
Dec. 14, 2016, 6:56 a.m.



same here cant equip them on any of my Tier 2 ships either


Posted: //
Dec. 14, 2016, 7:04 a.m.



Same thing here, only on my Ceres (T2 Tactical) it is taking the ability 1 slot with Tesla turrets too so my Beam Amp is not showing. Once in game, loadout info shows beam amp equipped but when actually playing, slot 1 has no ability at all, 2-4 have moved to 1-3 and 4 is blank.


Posted: //
Dec. 14, 2016, 9:30 a.m.



oh well...hope they fix it soon. and the launcher P2P needs to be fix...can't even change port number for p2p function.


Posted: //
Dec. 14, 2016, 10:09 a.m.



Ya i reported it in game.


Reddev32


Posted: //
Dec. 18, 2016, 12:49 a.m.


Updated //
Dec. 18, 2016, 12:49 a.m.

I have the same issue with the Cerberus and its Tesla Turrets upgrade. The ship itself is elite however.

I also reported it ingame.

This forum is restricted, posts cannot be made.