FORUMS


Update 1.4: Trafalgar



Posted: //
Dec. 13, 2016, 5:39 p.m.



  • My Trafalgar from before the patch had Weapon pulse booster equipped, after the patch I don't have it anymore.

  • To buy weapon pulse booster costs 43500 credits, way too much for a tier 2 ship.

  • My Trafalgar has 2 secondary slots (I have double Torpedoes), and no Perimeter module slot.

  • Equipping "upgraded" secondary weapons doesn't work for some reason on tier 1 vehicles ("Free" upgrade).


Posted: //
Dec. 13, 2016, 5:51 p.m.



Evangelia#6835 posted (#post-78066)

  • My Trafalgar from before the patch had Weapon pulse booster equipped, after the patch I don't have it anymore.

  • To buy weapon pulse booster costs 43500 credits, way too much for a tier 2 ship.

  • My Trafalgar has 2 secondary slots (I have double Torpedoes), and no Perimeter module slot.

  • Equipping "upgraded" secondary weapons doesn't work for some reason on tier 1 vehicles ("Free" upgrade).

This is exactly what is happening on my account also.


-----Tier 5 Ohkta Pilot-----Tier 5 Invictus Pilot-----Tier 5 Athos Pilot-----
-------------------------Fully Researched Tier 4 Fleet------------------------
-------------------What the @#$% are you talking about?----------------


Posted: //
Dec. 13, 2016, 6:12 p.m.



same here.


Posted: //
Dec. 13, 2016, 8:39 p.m.


Updated //
Dec. 13, 2016, 8:47 p.m.

Same here but I was able to fix this.

DEVS: You owe me 1500 credits it took to fix this smile

I had Weapon booster Pulse before the update. After the update weapon slot 3 has a duplicate torpedo salvo in it even though it is a slot 2 item and already equipped. Also it was shown that weapon booster pulse needed to be purchased even though I had it before the update.

If you enter a match like this it gets weirder. Slot 3 in game becomes whatever you had in slot 4 (module reboot for me) and slot 4 is totally empty.

I decided to spend 750 cred to buy WBP again, but it did not equip nor showed that it was able to be selected to equip.

FIX: I had to spend 750 more cred to buy auto guns. Once they equipped, I had the abilty to change them back to weapon booster pulse. Now I can't say whether I needed to buy WBP again or not for this to work, but that's how it did for me.


Posted: //
Dec. 14, 2016, 3:42 p.m.



Same here


Posted: //
Dec. 14, 2016, 6:57 p.m.



So I really don't want to spend money to fix this, but I can't equip my flac guns or for that matter any first slot guns to any of my ships what do I do?


Posted: //
Dec. 14, 2016, 8:10 p.m.


Updated //
Dec. 14, 2016, 8:11 p.m.

I lost my Booster too as well as unable to bring the jumpdrive ive equipped into any type of match even the trainer on my trafaglar.


Posted: //
Dec. 15, 2016, 9:59 a.m.



same here pfffs......


Posted: //
Dec. 15, 2016, 10:38 a.m.



i hope they fix this s**t and reimburse everyone for the trouble before the stress test on Saturday, otherwise i will not participate and i will encourage others not to participate as well.
Sorry, not sorry.


Posted: //
Dec. 15, 2016, 2:28 p.m.



I understand your frustration BUT...

Keep in mind that everyone here is a beta tester. This is a closed beta for crying out loud. It's no secret the moment you signed up for this.

Well, this is part of that territory plain and simple. We're here to experience stuff breaking... Better yet forcing stuff to break if possible so that we can report it back so those that go into the full release will have a smooth experience.

Don't delude yourself into believing anything otherwise as doing so would be completely foolish and short sighted while unnecessarily making your more frustrated than you should rightfully be.

If you want a bug free experience, don't do betas or early access games. smile

This forum is restricted, posts cannot be made.