FORUMS


Can't start game from launcher



Posted: //
Sept. 1, 2017, 8:59 a.m.



That launcher doesn´t know when the game is really ready to play even that there is huge button you can play it already. I downloaded the game and launcher told me i can play after 15 minutes of downloading. Nothing works and i was sad ,then i realize i can use that repair option. When i click that. Client suddenly (after 1 minute) realize that i need to download 17Gb of data ( why ready to play before - dont ask me ). Now i just need to wait for one free day to download that in one strike ,because that client always start to download from scratch. If you pause the downloading it forget everything already downloaded.
Described problems are just my amateur opinion based on real time observation and has nothing to do with true presented by developers :-) Have a nice day


Posted: //
April 16, 2018, 2:45 p.m.



0Hotel0#2043 posted (#post-94948) said:

Had the same issue, Restart pc, go to launcher, click the tool icon, click repair option. this worked for me

i cant actually click it i get a black screen and can do nothing but close it ive tried reinstalling it, repairing it, restarting my computer, but nothing fixes it what do i do.


Posted: //
April 17, 2018, 10:48 a.m.



Hi id contact support. You can find the link in my Sig below.


https://gb-live-privateassetsbucket-1359zn8x1as94.s3.amazonaws.com/images/Brother_Belial_Forum_Signature.original.original.png

i5 4690K @ 3.5GHz|8GB HyperX Savage 1600mHz|MSI H81M-E34|MSI GTX 960 Gaming 2GB|Seasonic S12G 650W|Win10 Pro X64| Corsair Spec 03 Case|

Dreadnought Support tool | Customer Support | Rookie Helping Hand Manuel

This forum is restricted, posts cannot be made.