FORUMS


Mouse Key Mapping



Posted: //
March 20, 2017, 9:40 a.m.


Updated //
March 20, 2017, 9:41 a.m.

So I wanted to bind module use buttons to the very now standard 'Fwd' and 'Back' (used in web browsing and what not) buttons on my mouse. However the game dosen't seem to register the click?

Any advice or is it not possible? Could it be my mouse?


Posted: //
March 20, 2017, 12:25 p.m.



Hey BadAlchemy

I don't believe this is an issue with your mouse. I'll take your feedback to our dev team that Mouse Button 3 and Mouse Button 4 should be bindable. Thanks!


Sean McIntosh
Dreadnought Community Manager


Posted: //
March 20, 2017, 1:58 p.m.


Updated //
March 20, 2017, 1:59 p.m.

***I reported some bugs a week ago, the thread was probably lost during last weeks "edit-error".
In there I reportet the mouse-button bug as well:

The (Purge) Beam "features" are already mentioned here
https://www.greybox.com/dreadnought/en/forum/topic/47038/
and here
https://www.greybox.com/dreadnought/en/forum/topic/47039/.


The weaponbeam itself is greatly inconsistent, and following quick targets it completly turns off (as it doesn't "lock on" any more).

Weaponbeams and Teslabeams (+Pods) alike sometimes keep firing at the last point the enemy ship was before it got destroyed. I am not sure if this is only seen by one self, or if its seen by other players (and enemies) as well: an invisibly ship with lightning arcs in every direction.

Ability No.4: I am sure this is not a bug unique to the Palos/Harwich/Cattaro, but as I only play this ship types I can only speak for them:
Ability No4, no matter what one places there (E-Generator, Autorepair, etc...), sometimes just doesnt activate as soon as the button (4) is pushed. It doesnt activate at all, one has to mulitple hit the "4" or stop pushing another button (WSAD, SPACE,SHIFT,E). I noticed this "feature" especially when trying to use "Emergency Evac", though I am not sure if this belongs to this ability itself, or is related to the nature of Em-Evac being used in an emergency, all I know is that it fails me sometimes by not /delayed activation.
As I am playing on 2 different systems (Laptop and PC) I doubt it is system-or Keyboard related,it happens on both of them

Putting Ability 4 to another key was not helpful. And putting it to one of my mouse-buttons is not configurable.(Dread doesnt support more then 3 mouse-buttons.)
And interesstingly trying to set anything to a mouse-button, the newly configured is NOT named, e.g. "Reload - Middle Mouse Button" INSTEAD it is named " Reload - LEFT ALT+MIDDLE MOUSE BUTTON" !
I am sure the error is within this sophisticated config.



Posted: //
March 20, 2017, 1:59 p.m.


Updated //
March 20, 2017, 2:01 p.m.

I reported that mouse-button-bug in a thread a week ago, but that was probalby lost during last weeks "edit-error".

*The (Purge) Beam "features" are already mentioned here
https://www.greybox.com/dreadnought/en/forum/topic/47038/
and here
https://www.greybox.com/dreadnought/en/forum/topic/47039/.


The weaponbeam itself is greatly inconsistent, and following quick targets it completly turns off (as it doesn't "lock on" any more).

Weaponbeams and Teslabeams (+Pods) alike sometimes keep firing at the last point the enemy ship was before it got destroyed. I am not sure if this is only seen by one self, or if its seen by other players (and enemies) as well: an invisibly ship with lightning arcs in every direction.

Ability No.4: I am sure this is not a bug unique to the Palos/Harwich/Cattaro, but as I only play this ship types I can only speak for them:
Ability No4, no matter what one places there (E-Generator, Autorepair, etc...), sometimes just doesnt activate as soon as the button (4) is pushed. It doesnt activate at all, one has to mulitple hit the "4" or stop pushing another button (WSAD, SPACE,SHIFT,E). I noticed this "feature" especially when trying to use "Emergency Evac", though I am not sure if this belongs to this ability itself, or is related to the nature of Em-Evac being used in an emergency, all I know is that it fails me sometimes by not /delayed activation.
As I am playing on 2 different systems (Laptop and PC) I doubt it is system-or Keyboard related,it happens on both of them

Putting Ability 4 to another key was not helpful. And putting it to one of my mouse-buttons is not configurable.(Dread doesnt support more then 3 mouse-buttons.)
And interesstingly trying to set anything to a mouse-button, the newly configured is NOT named, e.g. "Reload - Middle Mouse Button" INSTEAD it is named " Reload - LEFT ALT+MIDDLE MOUSE BUTTON" !
I am sure the error is within this sophisticated config.*


Posted: //
March 20, 2017, 2 p.m.



I have no idea why my above post is formated this way. This is really the most weird forum I ever experienced.


Posted: //
March 20, 2017, 2:04 p.m.


Updated //
March 20, 2017, 2:07 p.m.

I have this problem with my Razer Naga mouse as well. Some mouse buttons just don't register, like scroll left/right, mouse button 5, etc...

But there is a workaround, if you have the ability to rebind your mouse buttons to keyboard letters. So instead of "scroll left" or "Mouse Button 5," rebind the buttons to the letters "i" "k" "m" for example, and then they will work in Dreadnought.

-N03


Posted: //
March 20, 2017, 2:16 p.m.



Thank you Normandy,that is solving the problem. However, its the first game I experienced this kind of "malfunction".


Posted: //
March 20, 2017, 6:14 p.m.



DN_EmptyTuxedo#3505 posted (#post-114376)

Hey BadAlchemy

I don't believe this is an issue with your mouse. I'll take your feedback to our dev team that Mouse Button 3 and Mouse Button 4 should be bindable. Thanks!

Thanks Dev, much appreciated.


Posted: //
March 20, 2017, 6:48 p.m.



I can second what the OP says. For the moment I'm working around the problem by binding MB3 and MB4 as '[' and ']' and using those keys for commands, but it's not ideal. Mouse button support would be greatly appreciated!


Born to ride the storm description


Posted: //
April 30, 2018, 9:53 a.m.



Ever since the latest patch with the Conquest battles, mapping the right click button is impossible. If you set keyboard to defaults it reverts zoom to right click but I like switching to secondary with right click and it simply doesn't let you map it yourself. Center button mouseclick or scroll wheel up or down also can't be mapped, all could be useful for those that like controlling more with their mouse. I've tried built in laptop right clicks and several different mice and nothing will map besides the left mouse click.

Is there any reason why this is buggy all of a sudden?

This forum is restricted, posts cannot be made.