FORUMS


Kampfkraft

Statistics



POSTS


DN_EmptyTuxedo#3505 posted (#post-115465)


The current "meta" gives a lot of points and experience for kills and very, very little for assists. But this is a team-based game. Are there any plans to change this, or is this how we are supposed to be playing?

Properly tracking and awarding assists are a very important part of a team-based game, and we want to reward these team-play dynamics as much as possible to encourage players working together. The current scoring system in the game rewards the same 'kill' event to more than one player, so long as they have contributed a substantial portion of the damage (>50% of the base health value) to the destroyed enemy ship. Additionally, the person that gets the final hit on a ship also gets 'kill' credit. So in Dreadnought, kills are the assists in a way. In actuality, an 'assist' in-game is triggered when someone just scrapes the killed enemy, damaging >10% of that ship's base health, and that is the reason they award less score.


We are also planning to add a completely new system that will grant additional points for specific ship class and team-based actions, such as tanking and healing. Additionally, our current iteration of the scoring system grants the same amount of points no matter what ship tier you use. We know that isn't exactly fair, because there's a big difference between healing someone on Tier-I versus on Tier-IV. We are looking into changing this scaling as well and will have more info about that update in the future.


You already had that in ALPHA...why is it gone why does it take that long to put it back online?



DN_EmptyTuxedo#3505 posted (#post-115465)


The current "meta" gives a lot of points and experience for kills and very, very little for assists. But this is a team-based game. Are there any plans to change this, or is this how we are supposed to be playing?

Properly tracking and awarding assists are a very important part of a team-based game, and we want to reward these team-play dynamics as much as possible to encourage players working together. The current scoring system in the game rewards the same 'kill' event to more than one player, so long as they have contributed a substantial portion of the damage (>50% of the base health value) to the destroyed enemy ship. Additionally, the person that gets the final hit on a ship also gets 'kill' credit. So in Dreadnought, kills are the assists in a way. In actuality, an 'assist' in-game is triggered when someone just scrapes the killed enemy, damaging >10% of that ship's base health, and that is the reason they award less score.


We are also planning to add a completely new system that will grant additional points for specific ship class and team-based actions, such as tanking and healing. Additionally, our current iteration of the scoring system grants the same amount of points no matter what ship tier you use. We know that isn't exactly fair, because there's a big difference between healing someone on Tier-I versus on Tier-IV. We are looking into changing this scaling as well and will have more info about that update in the future.


You alleady had that in Alpha, why is it gone?


Cattaro. (I call it "N-78 Thanix" though)


Light Tactical and the only ship I intend to play.

With the last patch I get thrown even more often into halfway lost/won battles. Its extremly relaxing to wait 5+ mins to play 2 mins and get a maintenance-slap into the face. WTF?!

Interestingly those patches happen always at a good daytime for 'murican side of the world.

Vice-versa Europeans returning from work and wanting to play are getting their prime-time stolen.

The EliteStatus is still running.


If you copy the WoT system, copy the GOOD things too: they always grant every EliteStatus-owner a day or two (depending on off-time) as a compensation.

The "Sever Status" page shows that everything is okay. So you must be wrong. Try again later. (your EliteStatus is still counting down, so dont worry)


No,joke aside, its somehow offline for some 30mins now? I dropped out of a match and had to pay the maintenance of course, but that was already not possible, and trying to relog was impossible.

(your EliteStatus is still counting down, so dont worry)

Thank you Normandy,that is solving the problem. However, its the first game I experienced this kind of "malfunction".

I have no idea why my above post is formated this way. This is really the most weird forum I ever experienced.

I reported that mouse-button-bug in a thread a week ago, but that was probalby lost during last weeks "edit-error".


*The (Purge) Beam "features" are already mentioned here

https://www.greybox.com/dreadnought/en/forum/topic/47038/

and here

https://www.greybox.com/dreadnought/en/forum/topic/47039/.




The weaponbeam itself is greatly inconsistent, and following quick targets it completly turns off (as it doesn't "lock on" any more).


Weaponbeams and Teslabeams (+Pods) alike sometimes keep firing at the last point the enemy ship was before it got destroyed. I am not sure if this is only seen by one self, or if its seen by other players (and enemies) as well: an invisibly ship with lightning arcs in every direction.


Ability No.4: I am sure this is not a bug unique to the Palos/Harwich/Cattaro, but as I only play this ship types I can only speak for them:

Ability No4, no matter what one places there (E-Generator, Autorepair, etc...), sometimes just doesnt activate as soon as the button (4) is pushed. It doesnt activate at all, one has to mulitple hit the "4" or stop pushing another button (WSAD, SPACE,SHIFT,E). I noticed this "feature" especially when trying to use "Emergency Evac", though I am not sure if this belongs to this ability itself, or is related to the nature of Em-Evac being used in an emergency, all I know is that it fails me sometimes by not /delayed activation.

As I am playing on 2 different systems (Laptop and PC) I doubt it is system-or Keyboard related,it happens on both of them


Putting Ability 4 to another key was not helpful. And putting it to one of my mouse-buttons is not configurable.(Dread doesnt support more then 3 mouse-buttons.)

And interesstingly trying to set anything to a mouse-button, the newly configured is NOT named, e.g. "Reload - Middle Mouse Button" INSTEAD it is named " Reload - LEFT ALT+MIDDLE MOUSE BUTTON" !

I am sure the error is within this sophisticated config.*

***I reported some bugs a week ago, the thread was probably lost during last weeks "edit-error".

In there I reportet the mouse-button bug as well:


The (Purge) Beam "features" are already mentioned here

https://www.greybox.com/dreadnought/en/forum/topic/47038/

and here

https://www.greybox.com/dreadnought/en/forum/topic/47039/.




The weaponbeam itself is greatly inconsistent, and following quick targets it completly turns off (as it doesn't "lock on" any more).


Weaponbeams and Teslabeams (+Pods) alike sometimes keep firing at the last point the enemy ship was before it got destroyed. I am not sure if this is only seen by one self, or if its seen by other players (and enemies) as well: an invisibly ship with lightning arcs in every direction.


Ability No.4: I am sure this is not a bug unique to the Palos/Harwich/Cattaro, but as I only play this ship types I can only speak for them:

Ability No4, no matter what one places there (E-Generator, Autorepair, etc...), sometimes just doesnt activate as soon as the button (4) is pushed. It doesnt activate at all, one has to mulitple hit the "4" or stop pushing another button (WSAD, SPACE,SHIFT,E). I noticed this "feature" especially when trying to use "Emergency Evac", though I am not sure if this belongs to this ability itself, or is related to the nature of Em-Evac being used in an emergency, all I know is that it fails me sometimes by not /delayed activation.

As I am playing on 2 different systems (Laptop and PC) I doubt it is system-or Keyboard related,it happens on both of them


Putting Ability 4 to another key was not helpful. And putting it to one of my mouse-buttons is not configurable.(Dread doesnt support more then 3 mouse-buttons.)

And interesstingly trying to set anything to a mouse-button, the newly configured is NOT named, e.g. "Reload - Middle Mouse Button" INSTEAD it is named " Reload - LEFT ALT+MIDDLE MOUSE BUTTON" !

I am sure the error is within this sophisticated config.