Everytime i load the game it tells me that i need dx10.0 when i have dx already. I've downloaded the game 3 times already. Can you please tell me if this is a on going issue right now. The game was working fine last night